风险提示
风险提示: 律动 BlockBeats 提醒,根据银保监会等五部门于 2018 年 8 月发布《关于防范以「虚拟货币」「区块链」名义进行非法集资的风险提示》的文件,请广大公众理性看待区块链,不要盲目相信天花乱坠的承诺,树立正确的货币观念和投资理念,切实提高风险意识;对发现的违法犯罪线索,可积极向有关部门举报反映。或联系律动tousu@theblockbeats.com。
举报
简体中文 繁体中文
English(Google translation)
登录/注册
热门排行
热门搜索
没有找到搜索内容
查看更多
​Grin 2.0 版本发布,用户需升级后才可在分叉后继续使用 Grin (内附下载地址)
其他 2019年07月02日 08:43
硬分叉时 pre-2.0.0 钱包和节点将在此时停止工作。所有用户都需要升级到 2.0.0 版本才能继续使用 Grin。

区块律动BlockBeats消息,Grin v2.0.0 和 Grin-wallet v2.0.0 已经发布,本次 Grin2.0 版本的更新的主要目的是支持这次硬分叉的进行。Grin 建议大家利用这个机会尽快更新。

此次更新内容概况

Grin 2.0 版本

支持 Blockheader 版本 2 (post fork)

支持调整后 hf 继发性工作证明,「Cuckarood」

支持新的 Bulletproof 倒回方案

添加到节点 API 的版本信息函数

修改阶层->钱包通信使用 V2 钱包 API

Grin 钱包 2.0 版本

取消对 v0 和 v1 的支持,只使用 V2 格式。

取消对 V1 钱包 API 的支持。新的 V2 API 将继续维护,并在这里提供完整的文档

放弃对 Grin 节点 API 的旧版本的支持。钱包必须在 v2.0.0 或更新的 Grin 节点上运行,如果配置的节点是 v1.1.0 或更早,则将被停止活动。

支持新的 Bulletproof 倒回方案,它将适用于 v2.0.0 创建的所有输出。

二进制下载地址及详细说明

节点:https://github.com/mimblewimble/grin/releases/tag/v2.0.0

钱包:https://github.com/mimblewimble/grin-wallet/releases/tag/v2.0.0

请注意,Grin 升级将在区块高度 262,080 处发生,pre-2.0.0 钱包和节点将在此时停止工作。所有用户都需升级到 2.0.0 版本才能继续使用 Grin。

点击查看原文

硬分叉Grin分叉

扫码下载律动APP

专业区块链研究机构 与资讯平台